Customized HTML Landing Page crashes for few Users.

0
0

I have set a HTML Landing Page as Environment Default. It appears good to me. It appears good to Users who have Modeler permissions on the Environment. However, Users who do not have Modeler permissions on the Environment do not see it. For them, the Landing Page fails to load.

RESOLVED
Marked as spam
Posted by
Asked on 26 April 2021 5:20 am
64 views
Public question
0
Private answer

Hi,

  1. Are you using the External Website Widget or the HTML Widget? We highly encourage the former as the latter has a line limit, which may prevent you from copying in your entire landing page's HTML, CSS, Jscript into it. External Website makes it a lot easier to change pages over time and prevents users from tampering with the code.
  2. If you are using the External Website, you can point towards a preview page of a File type document (your HTML file). If using this option, make sure that the document is PUBLISHED. otherwise end users won't be able to see it.

For more information on correctly using landing pages, see this video: https://www.youtube.com/watch?v=Hb850jiO1WU&list=PLB8fuaXe-ChAwlOtql3QFpFLxoTmm1G4l&index=4&t=9s

 

Marked as spam
Posted by
Answered on 26 April 2021 10:52 am
0
Private answer

Yes - I was using HTML since it was directed towards a File inside the System. The Document was Published. But, still Users without Modeler permissions were not able to see it. I checked the settings in HTML and noticed that the 'Draft' value was set for 'True'. This was the reason Users who do not have Modeler permissions or 'Show Latest' permissions do not see the landing page. In fact, they were getting an nginx error.

 

Changing this value to 'False' and making sure the setting was changed as default for the whole environment resolved the issue. Now, all Users who log in are able to see the Page.

Next time, rather than HTML, I will try to use the External Website widget so that I do not run in to the character limitation issue.

Marked as spam
Posted by
Answered on 27 April 2021 12:07 am
0
Private answer

That's great to hear! I believe that your URL draft=true is also mentioned in the video I posted.

 

Thanks for your post! Others will benefit from it.

Marked as spam
Posted by
Answered on 27 April 2021 5:39 pm